The description for Event ID 3 from source Lync cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupt.

Environment Topology:
1 DC/GC and DNS running on Windows Server 2008 R2 with SP1
1 Lync Server 2013 installed on Windows Server 2012
1 Exchange Server 2010 SP3 with RU2
1 Client Windows 8 x64.
1 Office 2013 Lync Client and Office 2013 Basic Lync Client.
1 Certificate Authority and ADFS 2.0 Server
1 Forefront TMG Server 2010 SP2

I am not able to login to Lync 2013 client after the fresh installation of Lync Server 2013 with CU2. I am getting the error standard error message "The user name, password, or domain appears to be incorrect."

































Tried with different accounts as well, but still getting the same error message. I found an update for Lync 2013 client and installed it.















After the update, tried Login, still the same error message. Now I enable the logging on the client so that it will generate the event in case of failure. I found the Event ID 3, 1 and 12.









































































Now as per the event, there's something wrong with the installation or the files of Lync Client 2013 which got installed. I installed the full version of Office 2013 Lync Client, now I tried with Lync Basic client and it failed with the same error message.

































I decided to check the issue with Lync 2010 Client and installed the client after uninstalling the Lync 2013 client from the workstation.
Now I tried to login to the Test account and it worked, no more error with Lync 2010 client.





































Resolution/Workaround: Install Lync 2010 client.
I am not sure, why is it failing to login with Lync 2013 client, I am still looking into the issue and will update the post once I find the solution.

Cheers,

5 Responses to The description for Event ID 3 from source Lync cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupt.

  1. Hi!

    I'm suffering the same issue here. I have a company provided Office subscription and I goto my Office 360 to get my whole office installed. Everything works except Luyc 2013.

    I first get this log (error) in event viewer:
    The description for Event ID 3 from source Lync cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Lync
    800488ed

    Then, information:
    The description for Event ID 12 from source Lync cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Lync

    Then, another information:
    The description for Event ID 1 from source Lync cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Lync

    And lastly, same error:

    The description for Event ID 3 from source Lync cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Lync
    800488ed

    I've tried a number of fixes but to no avail so far. Hope you find something out soon.

  2. Gulab says:

    Before I suggest something, I would like to know what are the fixes you tried?

  3. Solved :), the problem is a client change thing.
    The lync 2013 client (32 bit for sure), is ok with a _sipinternaltls record for chat and a few others, but not for the whiteboard function. Looking at the IIS logs this whiteboard will give you a 401 and a few others. This means you do not have the rights to start a whiteboard session in the presentation.

    The client is NOT using a internal port, so use a _sipexternaltls record and point to the POOL over port 5061. Problem solved for all clients (running or not running).

    Have fun (took me 10 hours to find this major bug).

  4. I know this is an old post but has anyone got it to work I'm have the exact problems with the exact event ID's. Didn't appear that Patrick's solution worked for me.

  5. Gulab says:

    @Philip, I would like to know, did you tried Lync 2010 client? If yes, what is the result?

Leave a Reply

EXCHANGE RANGER