Error "Cannot bind argument to parameter 'Identity' because it is null.

I was upgrading Exchange 2010 SP1 to SP2, Hub Transport and Client Access Server upgrade completed successfully but it failed on Mailbox Server Role. See the below figure.

Deleted the Public Folder Database and continued installing the server and it failed with the below error.

Went into registry on the exchange server and deleted the Action and WaterMark key from the below location. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\MailboxRole
Started the installation of Mailbox Role and it failed again with previous error message.
Checked and found that when ever I run the installation it creates the Mailbox Database and those database are not mounted. One more thing is, after the installation fails MS Exchange Information store service is not running and I had to restart it manually.

Deleted all dismounted database and dismounted the Public Folder Database and took the copy of .EDB file and deleted the Public Folder Database. Replicated the domain controllers.
Started the upgrade and it completed successfully.

After the successful installation, everything is working fine except OWA. I am able to login to to mailbox using OWA but getting the below error message when doing a check name and composing or checking emails.


1: Start IIS Manager.
2: Expand the local computer, expand Sites, and then click Default Web Site.
3: At the bottom of the Default Web Site Home pane, click Features View if this option isn't already selected.
4: In the IIS section, double-click HTTP Redirect.
5: Select the Redirect requests to this destination check box, and then type /owa.
6: Under Redirect Behavior, select the Only redirect requests to content in this directory (not subdirectories) check box.
7: In the Status code list, click Found (302).
8: In the Actions pane, click Apply. 
9: Close IIS Manager
10: Find the Outlook Web App Web.config file on the Client Access server. The default location is <drive>\Program Files\Microsoft\Exchange Server\<version>\ClientAccess\Owa.
11: Make a backup copy of the file.
12: Open the original file using an editor such as Notepad. Don't use IIS Manager to edit the Web.config file.
13: Find httpCookies httpOnlyCookies="false" requireSSL="true" domain="" and change the requireSSL flag to false.
14: Save and close the file.

Checked the OWA and it's working fine without any error.

Cheers,



2 Responses to Error "Cannot bind argument to parameter 'Identity' because it is null.

  1. Inderjit says:

    Amazing Information.

    Thanks
    -Inderjit

  2. Gulab says:

    Glade you liked it.

Leave a Reply

EXCHANGE RANGER